1. Solution exception:Failed to load total results for window_group [1], state[0] for hour 0.0. 'tuple' object does not support item assignment

window-shade
window-groups
daylight

#1

Hi @mostapha and all you guys,

I’m running Radiance through the HB+ RunRadianceAnalysis component to get annual daylight.

I have a simple box with 4 “static” windows and 4 window-groups (such 4 glazings split into 2 parts, top and bottom).

I assigned radiance material to the windows and BSDF material to the window-groups.

BSDF materials (generated by using Window LBNL) describe glazing+venetian blinds. I have 4 states (for 4 different venetian blinds tilt angles: 0°, 25°, 45°, 60°.

When I “write” I don’t detect any problems and everything is fine, otherwise when I “run” I notice that:

  • 5Phase method doesn’t work
  • 3Phase method doesn’t work

This is the error:

  1. Solution exception: Failed to load total results for window_group [1], state[0] for hour 0.0.
    ‘tuple’ object does not support item assignment

Do you have any suggestions?

I’m missing something for sure…

Thank you very much!

Ornella


5-Phase 3-Phase error for example file and task test
#2

Here I attach the image about the simulation report (the error occurred is described at the end).

I hope this could be helpful…

Ornella


#3

Hi Nellis5,

I have found the same problem.

GB


#4

Are you using the latest version from GitHub? I remember we had this issue before and should have been addressed. It is happening because the initial values are saved as tuple and not list.


#5

Hi @mostapha,

thanks for your reply.

I tried to run the simulation by using 3Phase method and it works. Nevertheless, 5Phase still desn’t work.

I’m using the latest version from GitHub.

What do you mean with initial values when you say “the initial values are saved as tuple and not list.”?

Thank you!

Ornella


#6

I mean they way it is initiate in honeybee itself. I’m revising all the recipes right now for the next release. Is this an urgent matter or are you just testing the 5-phase workflow? I can try to fix it for the current version if you need it right now.


#7

Hi @mostapha,

it would be quite urgent for me to fix it now in the current version.

I have roller and venetian blinds and I’d like to have a more accurate estimation of direct sun component of the sky.

If you were already thinking about working on it, this could be the right moment to start :wink:

Many thanks!

Ornella


#8

Hello, has this been updated or addressed further? I’m having the same issue with a file. Works fine with 3phase, but I get the same error when attempting 5phase. Thanks!


#9

Hi @Riley.Johnson,

if you have the same problem, it turns out that the issue has not been fixed yet.

Dear @mostapha, could you please give us any feedback?

Thank you!
Ornella


#10

Disregard - after updating components, I was able to run 5phase without errors. However, that brings up a new issue (discussed here: ASE component - zero hours) where I am getting 0’s for ASE values. I know that should be the case with a 3 phase calculation, but I also am getting 0’s with DC and 5phase. Any tips?