1. Solution exception:The recipe failed to run with the following summary:

  1. Solution exception:The recipe failed to run with the following summary:

Scheduled 38 tasks of which:

  • 28 ran successfully:
    • 1 ComputeSphericalViewFactors(…)
    • 1 CopyGridInfo(…)
    • 1 CopyRedistInfo(…)
    • 1 CreateDirectSky(…)
    • 1 CreateModelOccSchedules(…)
  • 1 failed:
    • 1 RunEnergySimulation(…)
  • 9 were left pending, among these:
    • 9 had failed dependencies:
      • 1 LetPmvComfortMapFly(…)
      • 1 RestructureConditionIntensityResults(…)
      • 1 RestructureConditionResults(…)
      • 1 RestructureCspResults(…)
      • 1 RestructureHspResults(…)

This progress looks :frowning: because there were failed tasks

Use the report_out attribute of recipe settings to see a full report.

1 Like

The file is the one that comes with the installation package

I recommend using the latest version (LBT 1.5).

Hi,Chris.I’m open the “daylight _factor” or "gridbased"you supplied (My version is LBT1.5.0),but it still has such problem.Could you please tell me how to solve it?I also tried to use the component"HB Point-In-Time Grid Based " to get the luminance simulation, it also has such problem.



the Chinese character in cmd is mean another program is using this file and the process cannot access it.

I used the latest version but encountered the same problem like the post above. The GH file is the example file that comes with the installation pakage outdoor_comfort_under a tree. Are there other way to solve the problem?

I recommend opening separate discussion topics for each of these since all of these issues are different (the first line of the error message is just saying the simulation failed and the actual information about the error is on the other lines of the message and in the log files). This also means that there’s no way to know what specifically went wrong on your machine unless you upload the log file that is usually at:

C:\Users\[USERNAME]\simulation\[MODEL_NAME]\[RECIPE_NAME]\__logs__\logs.log

Do you have antivirus software (especially 360 Security Guard) installed on your computer?
I encountered a similar error, but I later found out that it was because ladybug tools identified a program in the radiance folder as a Trojan and deleted it during simulation by 360.
I personally recommend uninstalling 360 Security Guard and using Tencent Computer Manager instead or not installing similar antivirus software that is more conducive to ladybugtools related simulation programs. Then look for the name of the specific deleted file in the Trojan removal record from the antivirus software and copy a deleted file from the computer of another colleague who also has ladybugtools installed. Or uninstall ladybugtools from the control panel and reinstall it again.
Hope this solves your problem.


I don’t know if this is the file that you deleted by mistake.↓↓↓↓↓↓↓↓↓

gendaymtx.exe (31.5 KB)

You can take a look at my post below, I don’t know if it will help you.

Thanks for your help.I solve it successfully.

Thx for great advice, but I checked and there are actually no antivirus software on my computer. But when I run the UTCI component, it shows that some temp file is occupied. I don’t know wether that influence the outcome.

I found someone with the exactly same problem as me in the community. [UTCI with tree] And I posted my log files there. Could you please check it out? Thanks a lot! (UTCI recipe error - The process cannot access the file because it is being used by another process - #3 by DavidLuo)

1 Like

Hello all, try this, if this happens to anybody else, run Ladybug versioner object and update everything that should do the trick.

@chris Hi, Chris! I met the same problem, I posted my error report and log file there, could you please have a look? Thanks a lot! UTCI Map error, the recipe failed to run

It would appear that almost everyone who has reported this issue just did not check the units of their Rhino model and simulated rooms that were a few millimeters in dimension. Maybe I should just add a check for this before the simulation.

1 Like

I added an extra check for the units system that should address this with an explicit message:

1 Like