AnnualDaylight failing simulation

After a while of not using the AnnualDaylighting recipe and after updating to LBT 1.3.0 (using the PollinationRHGHInstaller-latest.exe).i’m getting the following (for the simplicity i’m testing the annual_daylighting sample file):

  1. Solution exception:The recipe failed to run with the following summary:

Scheduled 56 tasks of which:

  • 19 ran successfully:
    • 1 CreateDirectSky(…)
    • 1 CreateOctree(…)
    • 1 CreateOctreeWithSuns(…)
    • 1 CreateRadFolder(…)
    • 1 CreateSkyDome(…)
  • 14 failed:
    • 7 DirectSkyLoop(…)
    • 7 TotalSkyLoop(…)
  • 23 were left pending, among these:
    • 7 were missing external dependencies:
      • 1 AnnualDaylightRaytracing(…)
      • 2 AnnualDaylightRaytracingLoop(…)
      • 2 DirectSky(…)
      • 2 TotalSky(…)
    • 9 had missing dependencies:
      • 1 CalculateAnnualMetrics(…)
      • 1 LetAnnualDaylightFly(…)
      • 2 MergeRawResults(…)
      • 2 OutputMatrixMath(…)
      • 2 _AnnualDaylightRayTracing_4fe81c3cOrchestrator(…)
    • 7 was not granted run permission by the scheduler:
      • 1 AnnualDaylightRaytracing(…)
      • 2 AnnualDaylightRaytracingLoop(…)
      • 2 DirectSky(…)
      • 2 TotalSky(…)

This progress looks :frowning: because there were failed tasks

Use the report_out attribute of recipe settings to see a full report.
This is the log file produced.
logs.log (289.8 KB)

My feeling is that i did something wrong in the update process, but can’t think what it could be. The other option is that there could be a bug, but this is less likely.

Not sure this issue is related to this one, and that’s why i opened a new topic.

Any ideas?

This appears to be the same issue that was resolved here:

Do you have white spaces in your file paths?

If so, I recommend using either the latest Food4Rhino installer or run the LB Versioner. Technically, this last issue didn’t get fixed until after the first post of the Food4Rhino installer (I updated it last week with the fix). S that might explain why the latest PollinationRHGHInstaller-latest.exe does not have the fix yet.

Hi @chris,

No i don’t, As i said as an example of the issue i used the annual_daylighting sample file, as is. It has no path defined as input and my USERNAME has no white spaces.

I did with the Versioner, and just to be sure did it again right now. The error persists.

Any other suggestion?

Want to update:
Deleted completely the ladybugtools folder.
Installed with the PollinationRHGHInstaller-latest.exe.
Run the Versioner … twice (of course, restarted Rhino after each of them).
The problem persists.
As i wrote, no empty spaces in the simulation path.
This is the latest log file for debugging:
logs.log (239.1 KB)

What else can i check/do?

p.s. Noticed that the same errors appear with the AnnualIrradiance recipe. I guess that if it is fixed for the AnnualDaylight it will be also for this.

The same happens to me, But the error must be with the annual daylight file because I run another ones from 1.2 and they worked fine.
Thanks in advance.

Thanks all for reporting. I am going to investigate this now. This might be the result of this change that I pushed here a couple of days ago:

If that’s the case, then going back to LBT-Grasshopper version 1.3.11 with the LB Versioner should provide a temporary fix.

I just pushed a fix to the latest development version that should solve the issue experienced here:

Thanks again for reporting!

Also, our CI is currently down so the fix won’t be available with the LB Versioner for a day or two.

Thanks @chris,
Looking forward the CI will be up again.
In the meantime i replaced manually the file and it is working just fine now!!

hi @chris

Same happens with the Daylight Factor recipe. I will try to modify the relevant python file accordingly.


Thanks a lot @chris !

Hi All,
Thanks to a quick fix by our dev-ops guru, @AntoineDao , our CI system is up an running again! So you can now get the fix with the LB Versioner.

1 Like

Was having some of the issues discussed above and I just updated using the LB Versioner and Grasshopper Sync components - everything appears to be working. Thanks!

1 Like

Great! Thanks again.

If this happens to anybody else, run Ladybug versioner object and update everything that should do the trick.

Hello! Perhaps you can help? I just started learning Rhino and Grasshopper. I have a 90-day trial version of Rhino 7 installed. I tried to use sample annyal_daylight. I have an error:

"Solution exception:The recipe failed to run with the following summary:

Scheduled 11 tasks of which:

  • 4 ran successfully:

Hi Arina -

You are not providing enough information for anyone to be able to help you.
See Ladybug Tools Forum Guidelines - faq - Ladybug Tools | Forum.

Sorry, for some reason my message was not published in full. I’m just starting to study Rhino and Grasshopper. I have the same error as the author of the question. I work in Rhino 7, ladybug 1.6.0. I use a ready-made algorithm from ladybug-tools-1-6-0 - samples - honey bee - radiance - annual light day. When an error occurred, I found this topic and tried to upgrade to the latest version 1.6.6 via Ladybug versioner. The program gave me a notification that the installation was successful, I restarted Rhino and tried again. However, the error has not been corrected and the numbers 1.6.0 remain in the node signature, which means that the Ladybug version has not been updated. What would you advise to do in this case?

@Arina The Ladybug Versioner updates your installed version of Ladybug on you system but does not update the grasshopper file itself. Thus if you want to update your file you should use the component called “LB Sync Grasshopper File”.

The version you see on the Grasshopper components will not be 1.6.6. Those numbers will only increase when the actual component is changed.

Can you share the log file? You will find in the following path or something similar to it. Since the failing task is GenerateSunpath it might be the epw file. Previously there has been issues with special characters in the epw/wea file. Can you also share the epw file?