Changing Radiance parameters makes no difference

I’m trying to run an annual daylight simulation but it seems like changing the Radiance parameters is not making any difference:


unnamed.gh (43.1 KB)

As you can see I’ve set the bounces to 10 but the simulation still only takes 16s which is unrealistic. I’ve also tried getting rid of those “light splotches” by increasing AD and AS as per this recommendation, but nothing is changing.

I see now that reducing the -lw parameter makes the splotches go away.

I can also see that the results change with a very low number of ambient bounces (e.g. 1), however there still appears to be an upper limit for ambient bounces?

Hi @MaxMarschall,

For Annual Daylight, and other rfluxmtx/rcontrib-based simulations, you generally want to adjust -lw with -ad. In the other topic you learnt about the HB Radiance Parameter component. If you look at the value for -lw you will see that it is set at 1/(ad*100) for the different detail levels, which should likely be low enough to avoid splotches in most cases.

I believe that the reason why you don’t see a difference in the results with higher ambient bounces is because the rays at that point no longer contribute significantly, or they are terminated at that point. Every case is different but I imagine that you will not see much difference past 5 ambient bounces for your simple model.

2 Likes

Hi everybody, I am trying to run ANN but have been unsuccessful, the error is as shown in the image. I have tried with an epw file but it does not work, then with a URL but in both cases SKY fails. I have tried following the connections in this topic but I don’t know where the error is. I hope you can help me. Thank you very much.

Hi @claudia.gomez,

I was unable to recreate the issue with that particular weather file, so at least the problem is not that. Can you share the logs file? In your case you will find it here: C:\Users\gomez\Documents\Simulacion\annual_daylight\__logs__\logs.log

1 Like

Hi @mikkel this is the log file. Thank you!
logs.log (37.6 KB)

Hi @claudia.gomez,

gendaymtx, the Radiance program used in the three failed tasks, is not recognized on your system. Use the HB Config component to check the Radiance installation folder. In that folder you should have a file called gendaymtx.exe in the bin folder. In case you didn’t notice there is also a new version 1.5.0 of LBT, see how to install in the first paragraph here.

@mikkel I already checked what you mentioned and indeed I didn’t have that component of “gendaymtx” now I have it, I ran the simulation and it gave me other errors. I don’t know what is going wrong, I add the log file with this new issues. Again, thank you so much.



logs.log (106.9 KB)

Hi @claudia.gomez,

I am not sure how to fix the current issue, but here is what I would suggest. I see that you are missing multiple other files in your Radiance folder. I suggest that you use the single-click installer that I linked to in the previous reply, this should take care of the Radiance installation and update your core libraries. Remember to also update the components to the latest version.

1 Like

Hi @mikkel I installed the latest version of Radiance and it worked, thank you very much for your answers. Greetings!