Honeybee fatal - cannot find function file (gencumulative sky)

Dear all,

I would like to ask you for some feedbacks about some errors I got when using Honeybee for daylight simulations (radiation map using gencumulative sky and annual daylight simulation).
In the first case, we got the following error:

honeybee fatal - cannot find function file c:\ladybug\skylib\cumulativeskies\paris__orly_fra\paris__orly_fra_1.cal

even if the file has been created and it is not empty.

in the second one, the results file is empty so no simulations are running.

We are currently using Rhino 6 and the latest version of ladybug/ honeybee. We also changed the administrator rights as suggested in a old forum but without any success.

do you have any hints?
thank you very much

I add some files, they look good to me any expert hints?cumulativeSky_1_1_1_12_31_24.sk_radAnalysis.sky (224 Bytes)
cumulativeSky_1_1_1_12_31_24.sk_radAnalysis.sky (224 Bytes)
error.txt (92 Bytes)
PARIS__ORLY_FRA_1.cal (2.9 KB)
PARIS__ORLY_FRA_1_report.txt (76 Bytes)
PARIS__ORLY_FRA_cumulativeSky.bat (396 Bytes)
PARIS__ORLY_FRA.epw (1.5 MB)

There is nothing wrong, as in the integrity of the files, with your sky model.

This might be something related to path or access. I dont have access to a Rhino installation right now, but someone might be able to figure out the issue if you share the Grasshopper file as well.

Hi Sarith, thank you very much for your reply, please find attached the gh file. I have noticed that grasshopper is not able to find my results path also for other daylight simulation180628_LAMARSEILLAISE.gh (520.4 KB)
(annual analysis). This is strange…

Unfortunately the geometry wasn’t internalised in the file. Can you do that and upload again?

180628_LAMARSEILLAISE.gh (1.5 MB)

I added the new file with internalised data

Things are clear now @stefaniab,
I see from your file that you are trying to call the results with the HB_LookupFolder_Daylighting component. This is fine, but you need to provide the correct inputs. See image below:

The _studyType should be set as 5 (annual simulation. Was set as 1).
The important one: The _studyFolder. You have to delete the last item of the path (\annualSimulation). When you set the previous option to 5 the component dorsn’t need the full path, but only up to the name of the case as you gave in the simulation.
This also explains why you weren’t able to call previous simulation results.

Hope this addresses the issues.

Hi, yes it does but only for the daylight simulation (annual studies). I can’t solve the issue related to the radiation study.

Thank you very much for the help!

I did run the simulation at the bottom of the file and it run fine. What is the problem again?


The simulation do not run :Grid-based Radiance simulation
The component is checking ad, as, ar and aa values. This is just to make sure that the results are accurate enough.
Good to go!
Current working directory is set to: C:\Users\simulation\Documents\LAMARSEILLAISE\gridBasedSimulation
Failed to read the results!
warning - no light sources found

fatal - cannot find function file “c:\ladybug\skylib\cumulativeSkies\PARIS__ORLY_FRA\PARIS__ORLY_FRA_1.cal”

Runtime error (PythonException): Failed to read the results!
warning - no light sources found

fatal - cannot find function file “c:\ladybug\skylib\cumulativeSkies\PARIS__ORLY_FRA\PARIS__ORLY_FRA_1.cal”

line 331, in script

What is the content of the c:\ladybug\skylib\cumulativeSkies\ directory?
Do you have the GenCumulativeSky.exe file in the c;\ladybug directory? What is the size of it in case you have it?
The HB_gridBasedSimulation is giving the correct recipe?
Please check backwards that all inputs are fine.

Doc1.docx (1.3 MB)
I did some screenshots, you will find all the information on the attached document. The inputs look fine to me.

thank you for your help.

Hmmm … Tough one.
Can you disconnect the workingDir input? Just to check if the defaults locations make it work (c:\ladybug…).
I suspect this is an issue of permissions.
The results directory should look like this:


Hi Abraham, I have deleted the directory but nothing change. Do you think we should change permission for all users on the machine to make it work?
thank you

Is this a network computer or private?
If the former, i will ask the system manager. Also can you try the file on a private computer?
If the later, can you check in a different machine?

Running out of ideas …

Hi Abraham, the sysyem manager is not able to figure out the problem. I may try to reinstall all software again and try as well on another machine.
I hope to find a solution.

thank you


It might also be that you are using the wrong version of cumulative sky component. We had cases that users tried to use a 32 bit version on a 64 bit machine. Did you try to run it manually and see if it works. Also is gencumsky.exe file unblocked?

Hi Moustapha, I tried to reinstall the all package but without succeeding. Could you please copy here the 64 bit version of the cumulative sky component? I installed the LH package Ladybug 0.0.66 and Honeybee 0.0.63 [Legacy Plugins] - 2018-Mar-04. I am running out of solutions.
thank you