Image viewer in latest LB release

Hi,

I hope you are doing well and thanks for the continuous improvement of Ladybug tools.
I have one question:
As far as I see, ImageViewer is not included in the latest LB release. Is it correct?
If so, do you have suggestions for alternative workflows to work with the outputs from image-based daylight simulation?

Best,
Farhang

1 Like

@farhang.tahmasebi ,

This image viewer is definitely in the latest stable release of Ladybug. What might have caused you to think that it’s not is that the image viewer is a .gha files while most of the other components are a .ghuser files:

So, if you copied the image viewer component into the UserObject folder instead of the Libraries folder where it belongs, the image viewer component will not show up in your tool bar.

I hope that fixes it.

Thanks @chris for the quick and helpful reply. Problem solved.
It needed also some unblocking in my Windows, but it did work.

1 Like

Hello chris
This file( image viewer.gha) does not exist in the user object or in the library. It was also not exist at files in the rhino4food. Where should I download this?

Hi @Aliarch ImageView.gha file is in the gha folder of ladybug plugin package. Here is the screenshot.
image
If you can not find it , I have upload it for you.
FalseStartToggle.gha (25.5 KB) ItemSelector.gha (29.5 KB) Ladybug_ImageViewer.gha (44.5 KB)

2 Likes

Thanks dear friend for the quick reply @minggangyin
I put these files in this part of drive C. I also drop them in to the carve. But it is still not displayed in the toolbar.
What exactly should I do?
thanks in advance

In the folder, for each file try right click, properties, and tick unblock. Maybe that’s the problem.

2 Likes

hello
can you solve your problem?. I have a same issue, and ladybug_imageView does not come in my toolbar.
thank you so much in advance

@baharvojdani You can solve your question by following my tips above.

2 Likes

hi
it works thanks so much for helping

salam @baharvojdani
Can you explain exactly where you put these files?
thanks

You need to go to Grasshopper, File menu, Special folders, components folder, and paste the files there. Then right click on each file, select properties, and tick the unblock option if you see such an option in the properties window.

2 Likes

hi @farhang.tahmasebi, I have done all the process that you said, but I don’t have it in my ladybug

,and

Hard to say what the problem can be from the image.
If it is in the libraries folder and unblocked, it should work. Note that in the latest legacy version, I assume by mistake, you will get a tab called LB-legacy where all LB components are, but you also get another tab called Ladybug, which will have just the image viewer (if placed in libraries folder).

Farhang

thank you so much. yeah it is in another tab called ladybug.