simpleFoam.log not found

I downloaded the version from Food4Rhino that works with blueCFD.
Updated the components.
Still get the following errors. Anybody else having the same challenge?

Below is the error from the snappyHexMesh component

Below is the error from the Plot Residual component

@mostapha any thoughts?

This is the similar post

Hi @mostapha,

would it be worth going back to the old way of installing openFOAM?

Hi @devang, was there a real error in the run? Those messaged does not necessarily mean something has been wrong.

Hi @mostapha,

  1. The residual_values output of the Butterfly_Solution component remains 0
  2. Butterfly_Plot Residuals does not plot anything.
    what can we do to avoid that?

Hi @mostapha,
Any update on this?

Hi @mostapha,
Will you recommend going back to openFOAM instalation?

@mostapha I tried to go back the openFOAM way. I don’t believe I can do that. The components on Food4rhino and Github both work with BlueCoreCFD. Can you please confirm that?

Have you tried the BlueCFD core version yet?

Hi,@devang I have changed OpenFOAM windows version to BlueCFD core version in March,2019. The butterfly version 0.0.05 and BlueCFD core works fine on my computer without any error. I suggest you run BlueCFD outside Grasshooper and check BlueCFD worked fine or not.

Thanks @minggangyin, as you can see in the image below, the simulation is running however, there are no residual values.

Hi,@devang Here is the screenshot of result for the indoor airflow example. The residual plot worked fine.

This is still not working at my end. I see that the snappyHexMesh and solution components used by @minggangyin are dated January 12th whereas the components I download from food4rhino are dated Feb 22nd. What changed between that?

Hi,@devang Here is the Butterfly version I used. You can try this version. (153.4 KB)

Thanks @minggangyin, Can you also share Python files?

@devang Here is a zip file for the butterfly and butterfly_grasshooper folder.
butterfly python (99.4 KB)

Thanks @minggangyin for sharing the files. Unfortunately, the error remains.

@mostapha, any advice?

Hi devang
It seems that I have the same problem, residuals and timestep stay at 0 the whole simulation although the results look normal to me. The weird thing is that it started to happen today and it worked just fine for a couple of days before that. I’m using blueCFD and the newest BF version from f4r.

It doesn’t really bother me since I don’t need the residual values, but just wanted to let you know that you are not the only one with this problem

Thanks @stefan for reporting. I am working on getting to the root of this issue.