The URBANopt simulation stars but fails to run on Windows

Hello there
I have been having a similar issue. I am using the footprint example file and the simulation gives me the same error as Junoh.
I have updated ladybug and restarted rhino
I looked at the directory and the files are there.
I am attaching the screenshot of the command prompt

By the way, I am working on windows 10. Ladybug and Honeybee work fine

Thanks in advance

Hey @Thiago_Goes ,

I hope you don’t mind that I moved your comments to a new topic since it’s clearly different from the one you posted on previously. It looks like URBANopt is actually starting the simulation but then fails. Perhaps something became corrupted about your URBANopt simulation. Can you try uninstalling and then reinstalling URBANopt?

Hi @chris, no problem at all. My bad.
Unfortunately even after uninstalling (via removing apps in the control panel) and reinstalling the problem persists.

The excel file that I assume the UrbanOpt is looking for it is like this inside (don’t know if it helps)

Well, weird… but I just gave another path to the folder (to a folder on the desktop) and, even though the command prompt never closed, the simulation seemed to run. Got some results

Anyways… I am sending the command prompt that never finished. Seemed odd, as if the simulation directory does not exist (at least it is what is written). I really don’t understand, just got confused.

Hey @Thiago_Goes ,

Thanks for the full description here. I think the problem might actually result from the . in your Username. I will try to recreate this case when I get the chance and see if I can implement a fix on the Dragonfly/Ladybug Tools end. It’s possible that this issue is within URBANopt CLI end, in which case I will let the developers at NREL know and we can hopefully get it fixed in the next release.

Thanks, @chris.
If possible, let me know.

Hey @Thiago_Goes ,

I tried running some tests on my end but I am actually not sure what was originally happening here. I was not able to recreate the error by using a simulation folder like yours:

Furthermore, I can see that everything seems to be succeeding in the very last screenshot you posted even though everything is running out of a project folder with your unsername in the path.

Are you still able to recreate your original issue at all? If not, we might just have to chalk this one up to an odd fluke that seems to resolve tiself.

The command prompt never closes. If I do, the run urbanopt component gets the sqls. However, both the results reader give me an error. The first time I got the results (which generated the plot) I in fact closed the command prompt before finishing all 13 buildings.

The sql to EUI reader gives me the following error:

  1. Solution exception:index out of range: 0

And the aritimetic operation:

  1. Solution exception:Length of DataCollections must match in order to add them together. 12 != 6

I don’t know if it is supposed to be like this, but there are 13 branches, but some have multiple results

Ah, Ok. It seems like you just didn’t wait for the simulation to finish. On a high-end machine, the simulation can finish in 5-10 minutes but it will take somewhere between 30 minutes to an hour to finish on a typical laptop. Did you wait that long for the simulation to be done?

I am not sure.
I defenetly waited around 20 min or so. All the 13 folders ran. The last line is DONE, result = true.
I don’t know if I have to wait after that. Should I?

Just to replicate the case that I got dragonfly to plot some results, after the first 6 simulations are done and the command prompt starts another 6, I get no warnings or errors. However there are only six simulations.

I will keep on running a hour or so an post it here

Yeah… that was it. :man_facepalming:t4:

It does a few lines of “DONE, Result = true” before it finishes.
So it works, as long as I define a folder path different than the default.

Thanks for all your patience, @chris

1 Like

I am also getting the same error from URBANOpt now. It was running fine yesterday. I ran versioner and today I am getting:

  1. Solution exception:The URBANopt simulation failed to run.
    No results were found at:

It seems this is becoming a common error for people over the last month. @chris you already pushed a change for this correct? Is there a reason the versioner would not be correcting the problem? (382.0 KB)
This is a file that could use a sync, but even after syncing components I get the same error. I use a PC. I tried going back to 1.4.1, then letting versioner decide. Nothing has worked to get me beyond this error so far. I am also getting a ddy file error with the new 1.4.2 component for download epw.

Carrying this thread on here: URBANOpt not working after LB Versioner run

The file ran fine for me both before and after running the Versioner. You can see my explanation for what I think could have happened on that other post where you continued things.

I have same problem when run URBANopt,how do you gave another path to thefolder?