Unitary HP System on Supply Side

#1

How would I go about making a unitary HP system like this on the supply side? It is tied to a heat pump loop with a central cooling tower

#2

@Elliot_Glassman Could you attach an example osm file with one or two zones for me to test?

#3

This model may have more zones than you wanted, but it has the system that I am trying to replicate

Large Office Building CZ 5A.osm (1.2 MB)

#4

@Elliot_Glassman, I have added the Unitary System. Please update the Ironbug with following package.
Ironbug_UpdatePkg_v0.0.12.2.zip (742.5 KB)

Here is an example built based on your file.
UnitarySys.gh (619.2 KB)

I only did one test with above file, it runs successfully. But please keep me posted if you find anything that doesn’t work as expected.

-Mingbo

#5

Amazing! Thank you for the update. Works like a charm

#6

Hello @MingboPeng,

Is there a way to get this update for the OpenStudio 2.8 version, please?.

Best
Arturo

#7

@LUISARTUROREYESVALEN

Here is the update package for 2.8 Ironbug_UpdatePkgForOps2.8_v0.0.12.2.zip (743.3 KB)

#8

Thank you very much @MingboPeng!

#9

I think I may have found a bug… when I try to specify the Glychol Concentration, the condenser water loop throws an error. Running it through a number container first does not help.

Also, is there a way to create a fluid cooler? I only see cooling towers.

#10

@Elliot_Glassman
It seems the ObjParams components failed to guard the input type for Glychol Concentration.
In this case, openstudio is expecting the integer for the input value.
I will look into the code and try to fix it. but for now you can pass the value via “Integer”

Evaporative fluid cooler is not added yet, but if you could provide an example with a basic settings, that’d be great, and I can add it over the weekend.

-Mingbo

#11

Yeah the only problem is when I pass 0.4 as an integer, I get 0!

What can I provide you as an example? I am basically trying to change this Unitary system to have a fluid cooler not a cooling tower. Let me know what is most helpful to put together for you.

#12

Hi @Elliot_Glassman, I have added an integer type in objParam component, all values will be automatically converted to integer when it is needed.

I have added fluid cooler in following update package.
Ironbug_v0.0.12(20190623update).zip (264.1 KB)

Please let me know if it works.
Thanks
-Mingbo

#13

Hi Mingbo,

Thanks for the amazing update.

Is it possible that something in the plant loop branches may have broken in this update? For some reason all my plant loop components are only showing one branch now despite multiple inputs, and the OS file is missing the other branches (needless to say, the simulations won’t run)

#14

You are right, I updated the plantBranches component last week as well, and I did break the old component.

But here is a fixed update, please let me know if this works.
Ironbug_v0.0.12(20190624update).zip (260.7 KB)

#15

Thanks, Mingbo.

Despite specifying “EthyleneGlycol” in the fluid input, it is still showing water as the fluid in Open Studio file produced. Also, I am trying to specify a 40% concentration, and putting in 0.4 changes it to 0 because of the integer issue.

#16

That’s strange, I just tried again, it exports both value correctly. (I think the concentration value takes %, so 40 works, instead of 0.4)

#17

Yeah when I attach the DWLoop output to a panel I see the Glycol, but in Open Studio and the IDF it says water… not sure why its not translating.

Also in the IDF file I am trying to replicate, it is specified as 0.40, and the following documentation on Big Ladder seems to indicate its a decimal too:

Let me know your thoughts

#18

Could you give me a test gh file that doesn’t export osm file correctly with fluid type?
For the concentration value, I am not sure if it is a bug from openstudio or it is just how it sets. The only way to find out is build a simple model and try to run it with these settings. You can also check the idf file after the test run.

#19

I messaged you the file, let me know if you did not get it.

I don’t know if this is an Ironbug issue of more OS/E+ thing, or if it’s related to the fluid issue at all, but every time I substitute my two speed cooling tower (which works) for the two speed fluid cooler the simulation fails. Please let me know if you spot anything in the file I sent you.

#20

Hi @Elliot_Glassman,

I did a several tests with your file.

The first error I ran into is related to the Humidity setpoint manager. I think this related to humidify schedule in the zone, and also the location where you placed the in the airloop. Since this is not your main problem, so I removed all humidity controls (Humidifier and its set point manager) to recreate the fluid cooler’s issue.

Then, I got an error that says the “Heat pump loop” is too hot. I suspect this is somewhat related to your loop controls. Since the dummy boiler is not suppose to run at all, and setpoint managers after fluid cooler and boiler are the same as supply outlet setpoint manger, I removed them in branches.
With these adjustments, it runs now.

I attach the osm here if you want to take a look, and test at your end.unnamed.osm (155.2 KB)

So, with all these tests, at least we can rule out that the error is related to fluid cooler itself.
I’d suggest you to test the system with a small simple box model first, which helps to isolate issues and easier to solve. I’d also suggest you check the “.err” file in the study folder, this will provide some clues which part of model fails.

Please let me know if this still doesn’t fix your problem.
-Mingbo