“DF RUN URBANopt error”:Solution exception:The URBANopt simulation failed to run.No results were found at: C: \ Users \ HP \ simulation \ kkpp\ run \ honeybee scenario

Hello everyone, I’m facing a problem while using “DF RUN URBANopt” in Dragonfly for urban energy simulation. I’m sincerely seeking assistance as I’m unable to resolve it on my own. My urbanopt was still able to run yesterday, but today it’s not working. The only changes I made were deleting a few buildings, increasing the height of a few buildings, and deleting a large number of files from the simulation folder. What’s strange is that even when I tried simulating with the model before the changes, it still failed. The error message is shown in the image. Additionally, I tried using the “uo_config_test.gh” file that chris provided in a previous response to a similar question, but the result is shown in the image. I sincerely look forward to your help and guidance.

I also faced the same error.
I’m trying to find a solution. but still unable to solve.

Strangely I am also running into the same problem this morning, but I think it is operator error.

Actually, it looks like something is messed up in the ToGeoJSON component. Neither URBANOpt or the ModeltoOSM components are accepting my GeoJSONs.
I got the same result by running the “from_building_solids” example.

@chris or @mostapha could you help on this one?

Hi everyone,

Sorry for the late reply here and thanks for posting, @huloujun , @samustpon , and @Geo_curious , so that I can provide the answer.

This issue is not because you have done anything wrong in your model setup or your installation.

There was a breaking change to one of the external ruby gems that used by URBANopt, which has essentially broken the URBANopt simulation for all users no matter the version of Dragonfly or URBANopt.

In any event, I have pushed a patch a few days ago:

If you run the LB Versioner and restart Rhino, you can get a version of the software with the patch. You may also need to manually delete your old URBANopt project folder before running the new simulation just to make sure that the ruby gem with the breaking change is not there.


Thanks @chris. That did it.

1 Like

Thanks @chris finally i solve it.

1 Like

I ran the LB Versioner and restart Rhino,then all the components failed.Maybe I made a simple mistake. Could you give me some advice

Hey @huloujun ,

This is because you were using a slightly older Versioner component that did not have this fix in it that handles some new file permission limitations that Windows added:

The quickest way to fix the issue is by typing this into your command line while Rhino is closed:

C:\Users\[USERNAME]\ladybug_tools\python\python.exe -m pip install ladybug-rhino -U

Alternatively, you can uninstall, reinstall, and then use this Versioner component to update to the latest version:
fixed_lb_versioner.gh (6.3 KB)

… Or you can just use the free Pollination single-click installer here.

1 Like

Thanks @chris. After reinstalling the Ladybug tool, using the new Versioner componen, typing the code into cmd, and deleting the old URBANopt project folder, it finally worked, thank you very much!


hi Chris,
I an facing the same issue. but i am working in windows only.

  1. Solution exception:The URBANopt simulation failed to run.
    No results were found at:

Hi Sara,

I think I am having the same issue.

I have written this discussion post regarding the issue. Did you have a similar problem with GitBash?

Hey @amoroz and @sara1 ,

I moved your questions to this topic since you can see the answer above. The issue didn’t have anything to do with the error of running things on Mac where you had originally posted your question. Just run the LB Versioner component as noted above and you should be able to get URBANopt simulations running again on your machine.

@chris Hi~Chris. Thank you so much for your selfless help! And I have tried the method as @huloujun mentioned above (reinstalling the Ladybug tool 1.6.0, using the new Versioner component “fixed_lb_versioner”, typing the code into cmd, and deleting the old URBANopt project folder).
But unfortunately, it still failed :frowning:
Some screenshots are shown to describe the process. Everything seems right, but the cmd window cannot calculate effectively and only stays at “update” phase. Then after a long time, it still reported “Solution exception: The URBANopt simulation failed to run. No results were found at……”. I don’t know how to solve these questions.
Looking forward to your advice~Thanks!


Thanks, @Iris_YY ,

Your screenshots show pretty clearly that the Versioner process did not run correctly. If it had run correctly, then you would see that the lbt_gh version is something like 1.6.44 and not 1.6.0:


I realize that the Versioner is a somewhat advanced component and it can be tricky to get the hang of it if you have not used if before. For your case, it might be simpler to just download and run the free single-click Pollination Grasshopper installer from here:

That will definitely give you the latest version of the plugin, which contains the fix for URBANopt and will give you a completely compatible set of all components, libraries, and simulation engines.

1 Like

Hi Chris, Thank you for your prompt response. I will try the Pollination Grasshopper installer later. Also, I tested the versioner component again and got some error reports, as shown in the picture. It is possible that these reports could explain the reason why the version control feature cannot run properly.
It would be great if you could provide me with some guidance. Thank you!

Hi @Iris_YY ,

It looks like your internet connection is not good enough to use the LB Versioner component. Just download the Pollination Grasshopper installer and run it and you will be fine. Everything is self-contained in that installer so there is no risk of the internet timing out while the installer is running.

i got such error. and i used latest lb versioner

  1. Solution exception:All of the OpenStudio workflows failed to execute.
    Check the run.log files in the sub-folders of this directory:
    C:\Users\Install\Desktop\New folder (3)\run\honeybee_scenario

is there any help?

Uploading: BSSS.gh…

Hey @Aliarch ,

It looks like your .gh file didn’t finish uploading. But more helpful than the .gh file would be the logs that are at C:\Users\Install\Desktop\New folder (3)\run\honeybee_scenario. What do they say when you open them up in a text editor?