Error with PITView - part way through the 15 steps - at split the process step

Using the Image viewer and the sample file I have an odd behaviour.

As can be seen from the above, the checkScene recipe works fine, but when connected, the PITView component triggers an error where the component turns red, reports that it has only completed 9 of 15 tasks and that where it has stopped is the split process step.I presume this must be where the parallel processing part of the recipe is encountering an error in its count of the number of processors available? Could this be a user permissions issue. It does not occur for my computer, but does for almost identical (on a different internal network) computer on the student network.

Hi @MichaelDonn,

Are you able to share the logs file in the __logs__ folder in the simulation folder?


Did you set the number of workers manually? If the number of workers is set manually it will not try to find the number of processors available. I think this can rule out whether this is the issue. Although it should catch such an issue and set the workers to 1.

Hi @mikkel, thanks for the suggestion. I have remotely asked the student to supply the log file. It was an odd behaviour on his machine but not on others’. No-one had set the number of workers manually. We were establishing everything works with the sample files. Will get back with that log file when it arrives.

Meantime, I have also suggested he try the Workers = 1 setting for the HB_Recipe_Settings component to input to run_settings. I should have remembered the separation of workers/cpu count in this way, but wasted time in class puzzling where this input was missing from the PITView component! Thanks for the heads up.

Kia ora

I have looked more carefully at the log file and recognised the issue is a space character in the students’ “My Documents” file location. Fixed by moving his file locations out of that part of his disk…:

2022-04-10 11:25:59 INFO: [pid 11476] Worker Worker(salt=925092267, workers=1, host=JDAH-PC, username=FName LName, pid=11476) running SplitView(_input_params={“bsdfs”: “C:/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/model/bsdf”, “metric”: “luminance”, “octree_file”: “C:/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/resources/scene.oct”, “params_folder”: “__params”, “radiance_parameters”: “-ab 2 -aa 0.1 -ad 2048 -ar 64”, “resolution”: 800, “simulation_folder”: “C:/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/initial_results/indoorview”, “skip_overture”: “overture”, “view”: “C:/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/model/view/indoorview.vf”, “view_count”: 1, “view_name”: “indoorview”})
2022-04-10 11:25:59 INFO: SplitView: copying input artifact input_view from C:/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/model/view/indoorview.vf …
2022-04-10 11:25:59 INFO: SplitView: copying input artifact scene_file from C:/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/resources/scene.oct …
2022-04-10 11:25:59 INFO: SplitView: copying input artifact bsdf_folder from **/Users/FName LName/simulation/hb_sample_model_view/point_in_time_view/model/bsdf
2022-04-10 11:25:59 INFO: SplitView: finished copying artifacts…
2022-04-10 11:25:59 INFO: Started running SplitView…
2022-04-10 11:26:00 INFO: Usage: honeybee-radiance view split [OPTIONS] VIEW COUNT
2022-04-10 11:26:00 INFO: Try ‘honeybee-radiance view split --help’ for help.
2022-04-10 11:26:00 INFO:
2022-04-10 11:26:00 INFO: Error: Got unexpected extra argument (LName/simulation/hb_sample_model_view/point_in_time_view/resources/scene.oct)

Thanks for catching this, @MichaelDonn . This is actually a bug and I’m going to try pushing a fix for it tomorrow. You should be able to run this recipe from folders with spaces in the path and I had just messed up in the way that I had coded this.

FYI, @MichaelDonn , I just merged a fix for this case:

So, if you run the Versioner, you should now be able to run the Point-in-Time-View recipe in folders that have spaces in the path.

1 Like

Kia ora @chris. I feel a very real sense of deja vu. (Or a fading / failing memory)

New computer. Installed LBT. Run the versioner and sync’ed the sample file to test the viewbased render process and I get this:

Error message on the red FalseColor component is

  1. Solution exception:invalid literal for int() with base 10: ‘’

I have a student on her home laptop who gets the same visible behaviour but with a different error message (even after running versioner and sync’ing.

Oddly, if I connect the hdr file after the “AdjustHDR component” to the input of the falsecolor component it produces results. Is there a header reader issue?

Thanks for letting us know about this, @MichaelDonn . It looks like this is actually the same type of issue that @mikkel solved here:

However, this one affects a different part of the code. So it just results from the latest version of Radiance changing the format of its output on us. In any event, I just pushed a fix, which you can get with the LB Versioner in an hour:

Then, you can see that you get the output you expect:

Brilliant - thanks again @chris

Kia ora @chris

Sorry to bother you but I have a follow on question as I have found your solution worked for me, on my work computer and on my home computer, but not on a student’s laptop. There seems to be some connection to this other Discourse entry: "Solution Exception: Invalid result folder" on AnnualDaylight

There do not appear to be any spaces in Mackenzie’s file name or folder names.

The issue as it appears on the her laptop is this error is reported:

We have run through versioner multiple times. We have uninstalled and reinstalled her version of LBT.

We have used your most recent (6 hours old!) version of the sample file as a test - downloaded from GitHub as I was getting paranoid about the sync errors we were getting.

As an example of the LB Sync tool operation not quite working, we only sometimes got this error when updating the older sample as a test.

Sometimes the HB False Color Component was replaced and did not report an error.

At times on running sync, we only had the 1.4.1 False Color component, instead of the 1.4.2 version.

For a time, my home computer looked like this:

Both versions of the component worked!
If I dragged the component from the HB-Radiance dialog boxes, then we had this which also worked:

On the student’s laptop the following appeared:

PRIOR TO UPGRADING MY WORK COMPUTER I had the following message:

I suspect I had not run versioner enough times.

Running Versioner produced a corporate security message:

Which produced a surprising batch file dialogue window that I never saw on my home desktop,

Note: in an earlier step on my own computer I closed Rhino, deleted the dotnet folder and LBT versioner would not work at all - in fact LBT would not work. I re-installed LBT from scratch at this point.

Then it clearly worked for me:

I have attached her Radiance PITView Log file and the reports of updating the LBT version (Doc1 the first time; doc.txt the second), in case this helps.
doc.txt (2.2 KB)
Doc1.txt (2.2 KB)
logs.log (133.4 KB)

Hey @MichaelDonn ,

There’s a lot of extra info here but only one possible bug. That “Non-zero return code” issue that your student is getting is specifically because they are using a version of Radiance that is somehow incompatible with the latest FalseColor component. What does the HB Check Versions component tell you is the version of Radiance that your student is using? Anything that is this version or newer should work correctly:

FYI, I would recommend that your students install Ladybug Tools by means of the free, single-click Pollination Grasshopper installer. These installers always come with a compatible copy of the simulation engines, which will likely alleviate cases like this.

And, yes, we recently updated the Versioner so that it can change the version of the LBT plugin even when Ladybug Tools is installed in “Program Files”, which requires Admin privileges.

Kia ora @chris.

I guess I was going with the installer approach that I understood. Mackenzie was self-taught in using the software in another programme at the School. Last week, she realised I might be a resource that could help with some of her skills development. I pointed out the value of the sample files in showing her how to work (to then she had been using youtube, very successfully I might add). I also wanted to work through with her how she had installed LBT. I will investigate with Mackenzie using the Pollination installer.

I did check the version of Radiance against the Compatibility Matrix, and her version was OK.

And that version of radiance was the same as for me - we even checked online to see what version of Radiance is downloadable.

I note that your example you have a date of 2021-8-22 (22nd August 2021?) while she and I have

Which is what the compatibility matrix states and works for me and not her.

I will also suggest she download again and re-install Radiance…

Thanks for the instant assistance



I did not ask Mackenzie to reinstall Radiance as the HB version tool seemed to be reporting all was OK. I ignored my gut feeling, and unfortunately wasted her and your (@chris ) time. My apologies.

Downloading Radiance and re-installing it solved the problem. She reports (thank goodness for text messaging) that all now works!


1 Like

Hey @MichaelDonn ,

No worries. I’ll admit it’s odd that the version of Radiance was 2021-3-28 or greater but Falsecolor was not working. I guess something else might have been corrupted about her Radiance installation. In any event, I am glad that reinstalling Radiance fixed it.