Installing beta from github

installation
#1

Since i’m struggling with annual daylight simulations, (see 5-phase annual daylight won't work with example files) i tried to install the latest versions of honeybee+ for grasshopper to be able to use the newest example files.

i’m running on windows, rhino 6SR19, python 3.6, radiance 5.

My approach was:

  • install honeybee and ladybug with pip install … . because of fileaccess i had to do this as administrator. the main scripts where copied to C:\Program Files\Python36\lib\site-packages\
  • copied the userobjects from https://github.com/ladybug-tools/honeybee-grasshopper/tree/master/plugin/grasshopper/userObjects to my appdata…directory
  • since the main scripts weren’t found when placing an userobject in grasshopper i copied them to \AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\honeybee\

Sadly that didn’t work. Is there an offical guide on how to uses the betas from github?

Best regards,
Heiko

#2

Hi @HeikoWoehrle, There is an update component that does take care of the installation process. I will check the other question shortly. Meanwhile a couple of notes.

This won’t work for Grasshopper since Grasshopper doesn’t look into Python folder. You should copy them to scripts folder which you mentioned in step 3. Also keep in mind that ladybug and honeybee are lbt-ladybug and lbt-honeybee on pip.

Finally installing honeybee will also install ladybug for you as a dependency. Again this doesn’t help with Grasshopper installation but FYI.

pip install -U lbt-honeybee

#3

Hi Mostapha,

reading the above comments I get the sense that it might be related to a problem that stumbled into trying to up-date HB [+] recently. I have been running some image based simulations using different BSDF files with HB [+] 05 version Oct 2018, however the results were not satisfactory, so while looking for a solution I tried updating. Now I am experiencing some issues with the up-date component in Honeybee [+]. Updating has worked fine for previous versions but this time for some reason it is not working. I am not quite sure what exactly the problem is (please see screenshot attached). Components from previous definitions won’t work anymore neither. Is there a known issue to this problem, or any suggestion for solution?

Many thanks for looking into this.

Kind regards

Jan

#4

@Jan, Can you try the new update component that I shared here?

#5

Many thanks for the quick reply. The installer component worked, however after reopening Rhino and Grasshopper all HB [+] components give the same error message (see screenshot). I would be very grateful for any suggestion to what might be the issue.
Cheers

HB[+] Daylight Autonomy incorrect scattered results
#6

What do you see if you double click on the component and run it. That should give you a longer error report with the line number. This is an strange error not sure what is going on. Knowing the error line can help.

#7

Hi Mostapha, I’m a bit of a beginner but I get the same error today. Here is what it looks like when I “test” the python component:

#8

Hi Mostapha, thanks for following up on this. Please see below a screenshot of the error messages. Looks like several of the components did not up-date. Let me know in case you would need the full text error report or file for further diagnosis.
image

#9

@Jan and @Sarahh ,

I think that I might know what the issue is. The update component has, itself, been updated over the last few months. If you drag/drop your (newer) update component onto the canvas, run it again, and restart Rhino/Grasshopper, do you still have that error?

#10

Hi Chris, thanks for looking into this. I tried out what you recommended, however it doesn’t solve the problem. I have attached a screenshot and a copy of the python script of the up-date component after running it. Hope that gives more insides to what might be the issue.

Report_Up-date Honeybee[ ].txt (6.9 KB)

#11

@Jan ,

What’s the error that you are getting on the update component? This is the heart of the reason why everything is not working. I would also recommend only having the update component on the canvas (no other components).

#12

Hi Chris, this what I am getting on a clean canvas:


#13

Ah, sorry that I didn’t notice the error message in your previous post was for the update component.

I also just realized that you are using Rhino 5 and that is the primary reason why it is not working (there are no issues in Rhino 6). It looks like it is coming down to differences in the versions of IronPython between Rhino 5 and Rhino 6. I will try to investigate it now but I can confidently say that using Rhino 6 will fix your issue here.

#14

Ok, I found this issue. Apparently it’s the result of this change that I recently pushed:

I guess this “correct” way of finding the current directory of a file isn’t supported in the (very old) version of IronPython that Rhino 5 uses. I think that I will just revert this change for now and that will fix it. Will post back here once the work is done.

#15

Ok, I finally got to the bottom of it and I have a correction to my previous statement in that I had it backwards. The issue was not because that recent change broke anything but because that change was the right one (which fixes everything) and I had not yet merged it into the official copy of our Python libraries.

Everything is up-to date with our official copies of the libraries now and I have the HB[+] update component working out of Rhino 5 on my end. Please give it another try @Jan and fingers crossed that it should work this time.

#16

It seems to be working for me. Thank you!

As a side note: Super amazed at this community! As a beginner I’m learning a lot from everyone here! :smiley:

#17

Awesome! Thanks for testing, @Sarahh and thanks again for reporting the original issue @Jan .

1 Like
#18

Hi Chris, unfortunately it’s still not working for me, I have just tried on another PC, but still Rhino 5…not sure what is happening, maybe the error is on my side. Until now all up-dates have been working fine so far. Is there a way of installing the up-date manually with a direct download? Just thinking of how to navigate all possible directory issues…

#19

@Jan ,

If you are getting the exact same error, then there is some part of the update process that you are missing (ie. restarting both Rhino + Grasshopper, only running the update component on the canvas, etc.) . If you are getting a different error, then let me know and we can work through it.

#20

Hi Chris, I have followed thru the up-dating process as by your description above, the up-date component is now not throwing out the error message anymore, but after reopening some of the components doesn’t seem to have up-dated and show the following error message:

“Solution exception: pattern must be a string or compiled pattern”

(see screenshot below)