Solution for Ladybug / Honeybee not working with Rhino Inside Revit

Hello everybody,

Many forum posts both here and on the Rhino discourse have concerned Ladybug/Honeybee not working from Rhino Inside Revit. Examples are this, this, this, this, this and this.

Some had Ladybug/Honeybee not working at all, some like me had that Honeybee Energy components were not able to find _sqlite3, etc. At our office we used Rhino 7 (various builds) and Rhino Inside Revit (various builds) with Ladybug/Honeybee 1.6.0.

The proposed solutions to these issues inculded:

  • installing Ladybug/Honeybee from inside Rhino Inside Revit, as suggested by PaulWintour
  • running the set_python_path.bat file, as suggested by Chris Mackey
  • setting the python paths manually as suggested by RdK

These worked for some people, but not for all. It also did not solve my _sqlite3 issue for Honeybee Energy, I tried all of the above solutions. If I made the energy analysis through Rhino (not Rhino Inside Revit), the components were working fine.

Finally however, I did find a solution! At our office we use an additional module for our Revit called ‘pyRevit’. This program installs certain python and ironpython modules that are used for making Revit add-ons. Before installation of this module Honeybee was working. In our case, this program is interfering with the IronPython referrals of Ladybug/Honeybee. Uninstalling pyRevit from our Revit 2022.1 solved the issue of Ladybug/Honeybee not working in Rhino Inside Revit, so we can now run all our analyses again! :partying_face:

Please share and let others know, as they too may perhaps have this issue. Thank you all for your help and good luck with your work!

Greetings, Okan

Thank you for finding a temporary fix, have you reported that conflict to either teams ? Pyrevit or Ladybug ?

Hi, yes I’ve reported it to PyRevit and to McNeel; I have only shared it with LB/HB through posting it here :slight_smile:

Gotcha, that should be enough, maybe post it on their github, I’ll do it

1 Like