Ladybug Tools 1.2 and Rhino Inside Revit issue

Hi there

I’ve been having some issues with the new ladybug tools. So far, everything seems to be running fine in Rhino 7, but when I try using LB 1.2 in Rhino Inside Revit, all components turn red and display the following error.

Not sure if this is a RIR issue or on LB’s end?
Any suggestion will be greatly appreciated.
Thanks

2 Likes

I’m having the same issue using Ladybug/Honeybee v1.2.0 with Rhino Inside Revit. Scott Davidson from Rhino passed the issue over to this Discourse when someone posted the issue:

Problems with Rhino.Inside.Revit and python-based plugins (Honeybee) - Rhino.Inside / Revit - McNeel Forum

1 Like

same issue here. Has anyone found a solution to this?

I had this issue but managed to fix it. LBT in Rhino7 (standalone) was working fine, but not in Rhino Inside Revit.

I ran the installer from within RIR and if fixed my issue. Basically, the problem was that it could find the Python libraries, which is now resolved.

I am pretty sure that this issue results from the fact that McNeel doesn’t create the User settings file that sets the Rhino IronPython path until the very first time that you open Rhino Inside Revit. So opening Rhino Inside Revit after you installed Ladybug Tools causes this import error.

Rerunning the whole installer after the first time you open Rhino Inside Revit should fix it (as @PaulWintour suggests). But a quicker fix is just to rerun the set_python_path.bat file inside your ladybug_tools installation folder.

2 Likes

I had it HB working on Rhino 7 but when opening through Rhino Inside Revit it wasn’t working, I was getting the error “module not found”.

Running the set_python_path.bat fixed it immediately. Thanks for the suggestion Chris!

1 Like

I also had the same issue

Hi,
I have the same problem with Ladybug/Honeybee v. 1.6.0. When I use HB nodes, I get the message e.g: “1. Solution exception:
Failed to import honeybee:
No module named honeybee.boundarycondition”

I followed the procedure:

  • rerun the set_python_path.bat file inside your ladybug_tools installation folder.
  • open Rhino/GH through the RhinoInside Revit plugin

I also tried to inverse this procedure.
In both cases, it doesn’t work.

Do you have any suggestion how I could fix it? Maybe in that case i should keep Revit and RiR plugin open and reinstall Ladybug Tools?

Many thanks!

Best regards,

Julia